Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

jQuery 3.0 disponible en téléchargement
La nouvelle version de la bibliothèque JavaScript met fin au support des versions 6 à 8 d'Internet Explorer

Le , par danielhagnoul

102PARTAGES

5  0 
En développement depuis octobre 2014, jQuery 3.0 est enfin disponible. S’il s’agit d’une continuation de la branche 2.x, la nouvelle version de la bibliothèque JavaScript introduit toutefois quelques changements entrainant une rupture, ce qui justifie le passage à une version majeure. L’équipe de développement de jQuery 3.0 estime cependant que la rupture ne devrait pas réellement affecter beaucoup de gens. Les prochaines versions de la branche 3.x ne devraient pas non plus causer trop de problèmes en ce qui concerne la mise à niveau du code existant.

La version 3.0 de jQuery Migrate, le plugin qui sert à tester la compatibilité des codes existants avec la nouvelle version de jQuery, est également disponible. Son utilisation est fortement recommandée pour vous aider à identifier et résoudre les problèmes de compatibilité.

Comme annoncé parmi les changements lors de la sortie de la version bêta de jQuery 3.0 en janvier dernier, cette nouvelle branche met définitivement fin au support des versions 6 à 8 d’Internet Explorer (IE). Il faut rappeler que Microsoft a déjà annoncé la fin de vie des anciennes versions de son navigateur. Pour ceux dont les projets reposent sur IE 6-8, ils devront donc utiliser la version 1.12, la dernière de la branche 1.x. L’équipe de développement de jQuery explique également avoir tiré parti des API Web plus modernes, là cela était nécessaire.

Les versions les 1.12 et 2.2 de jQuery continueront à recevoir des correctifs critiques pour un temps, mais elles ne recevront aucune des nouvelles fonctionnalités ou révisions majeures.

Comme autre nouveauté dans cette nouvelle branche, l’équipe de jQuery lance également une version baptisée « Slim » qui est plus légère et plus rapide. Si la taille n’est en général pas à l’origine de problème de performance avec jQuery, la version Slim est d’environ 6 ko plus petite que la version normale en gzip. Ce qui permet de passer de 30 ko à 23,6 ko. Cette version légère exclut en fait les modules AJAX et effets, et cible donc les développeurs qui n’en ont pas besoin.

jQuery 3.0, jQuery 3.0 (version compressée)
jQuery Migrate 3.0, jQuery Migrate 3.0 (version compressée)
jQuery Slim, jQuery Slim (version compressée)

Source : Blog jQuery

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de danielhagnoul
Rédacteur https://www.developpez.com
Le 08/07/2016 à 21:54
jQuery 3.1.0 est disponible

Source

Nota bene : je ne suis plus l'actualité jQuery car je ne l'utilise plus. Si la chose vous intéresse, veuillez prendre contact avec vermine.
1  0 
Avatar de ctxctx
Membre à l'essai https://www.developpez.com
Le 17/06/2016 à 14:49
Maintenant que jQuery laisse de côté de plus en plus d'anciennes versions de navigateurs et que les nouvelles versions de navigateurs prise en charge supportent de plus en plus les standards sans avoir à (trop) attendre des années, quelle est donc l'utilité de jQuery par rapport à du VanillaJS ?
0  0 
Avatar de champsy_dev
Membre averti https://www.developpez.com
Le 24/06/2016 à 22:41
La syntaxe peut être,

VanillaJs:
Code : Sélectionner tout
1
2
3
4
var s = document.getElementById('thing').style;
s.opacity = 1;
(function fade(){(s.opacity-=.1)<0?s.display="none":setTimeout(fade,40)})();
JQuery :
Code : Sélectionner tout
1
2
$('#thing').fadeOut();
Bon par contre pas la vitesse d’exécution sa c'est sur.
0  0