Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Chrome va bloquer par défaut tous les plugins NPAPI à partir de janvier 2015
Et mettra fin à leur support en septembre

Le , par Hinault Romaric

128PARTAGES

1  0 
Dans l’optique d’améliorer la sécurité, la stabilité et la vitesse d’exécution de son navigateur, Google annonce que Chrome procédera au blocage par défaut de tous les plugins NPAPI (Netscape Plugin API) à partir de janvier 2015.

Le géant de la recherche vient de publier une feuille de route sur le retrait progressif de la prise en charge des plugins NPAPI dans Chrome, jusqu’à leur suppression complète du navigateur en septembre 2015.

Pour rappel, les API Netscape Plugin avaient été développés à l’origine pour le navigateur Netscape, avant d’être adoptés rapidement par les autres navigateurs. Avec l’évolution du Web et des navigateurs, son architecture qui repose sur les années 90 est devenue l’une des causes principales « de bogues, d'incidents de sécurité, et de complexité du code », selon Google.

Compte tenu du fait que les plugins NPAPI étaient encore utilisés par un nombre non négligeable d’internautes, Google avait opté en janvier 2014 pour un blocage des plugins NPAPI en dehors de ceux contenus dans une liste blanche, dont Silverlight (encore exécuté par 11% d’utilisateurs de Chrome le mois dernier), Google Talk (7%), Java (3,7%), Facebook Video (3%) ou encore Unity (2%).

À compter de janvier prochain, tous les plugins NPAPI seront bloqués par défaut, même ceux contenus dans la liste blanche. Les utilisateurs seront invités à autoriser manuellement l’exécution des plugins NPAPI pour les sites qui en ont besoin.

À partir d’avril 2015, Google désactivera par défaut le support de NPAPI dans Chrome et ne permettra plus la publication des plugins utilisant cette architecture dans le Chrome Web Store. Plus aucune autorisation ne sera demandée à l’utilisateur. Les plugins NPAPI ne fonctionneront plus.

Néanmoins, il sera toujours possible pour les utilisateurs avancés et les administrateurs de réactiver le support de NPAPI à partir d’une option de configuration ou via la politique de l’entreprise.

Ce sursis durera jusqu’en septembre 2015, date à laquelle Google mettra définitivement fin à la prise en charge de NPAPI dans son navigateur.

Source : Google

Et vous ?

Qu'en pensez-vous ? Utilisez-vous encore des plugins NPAPI

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de LeclercqBertrand
Membre du Club https://www.developpez.com
Le 25/11/2014 à 12:29
NPAPI fait de la résistance !

(je sais, c'est moyen)
1  0 
Avatar de JCB001
Membre du Club https://www.developpez.com
Le 27/11/2014 à 11:14
Cela signifie t-il qu'en septembre 2015 le plugin java étant désactivé aucune applet java (peu fréquentes il faut reconnaître) ne fonctionnera ?
0  0 
Avatar de Battant
Membre averti https://www.developpez.com
Le 27/11/2014 à 14:19
Bonjour,

Qu'en est-il de la gestion de ces plug-in par Firefox ?

Merci pour votre réponse

Salutations
0  0