Newsletter Developpez.com

Inscrivez-vous gratuitement au Club pour recevoir
la newsletter hebdomadaire des développeurs et IT pro

Forum du Club : amélioration des performances générales
Venez donner votre ressenti

Le , par Anomaly, Responsable technique
Chers membres du Club Developpez.com,

Depuis la mise en place de la nouvelle version de Developpez.com, nous avons été victime de notre succès avec un forum souvent lent en heures de pointe. Considérant que les performances d'affichage comme un élément tout à fait prioritaire pour votre confort, nous avons travaillé d'arrache-pied ces dernières semaines à améliorer les performances du forum. De nombreuses choses ont été faites dans ce but :
  • Remplacement des différents serveurs par des serveurs plus modernes et plus puissants
  • Regroupement des serveurs essentiels dans le même datacenter pour réduire les latences d'accès entre les différents serveurs
  • Moteur interne de recherche forum remplacé par un système différent plus rapide et plus léger
  • Nombreuses optimisations apportées à la base de données, incluant une montée en version, des changements de formats et l'utilisation de paramètres mieux adaptés au nouveau forum


Même si chacune de ces évolutions et pistes prises de manière individuelle n'ont contribué que de manière modeste à l'amélioration des performances, le tout mis ensemble semble avoir porté ses fruits en restituant des performances correctes pour vous assurer le confort que nous vous devons vous assurer.

Qu'en pensez-vous ? Avez-vous remarqué et apprécié les améliorations de ces dernières semaines ?


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de TiranusKBX TiranusKBX - Expert confirmé https://www.developpez.com
le 07/04/2014 à 13:57
Je suis pas mécontent de cette amélioration car parfoit les pages mettaient 30 secondes à charger
Avatar de tomlev tomlev - Rédacteur/Modérateur https://www.developpez.com
le 07/04/2014 à 14:13
Ah, il me semblait bien que ça marchait beaucoup mieux depuis quelques jours... Bon boulot
Avatar de transgohan transgohan - Expert confirmé https://www.developpez.com
le 07/04/2014 à 15:31
Etant derrière un proxy d'entreprise très lent j'ai tout de suite vu la différence.
Merci pour le travail effectué.
Avatar de rupteur rupteur - Membre actif https://www.developpez.com
le 07/04/2014 à 16:00
coté developpez.com affichage immediat des informations.

coté developpez.net (forum), j'ai 2 à 3 secondes de latence pour qu'une rubrique s'affiche.
mais rien de rédhibitoire. (de plus cela vient peut-être de la connexion)

Avatar de forthx forthx - Membre confirmé https://www.developpez.com
le 07/04/2014 à 16:03
Il y a une amélioration certaine par rapport aux premiers jours de cette version!

Habituellement je peste contre les mises à jour, ici, je m'y retrouve plutôt bien, les fonctions que j'utilisaient sont toujours la, et a présent c'est navigable sans peine (éventuellement même sans JavaScript ). Ca rame un peu sur mon eeepc mais dans la moyenne des autres sites récent. Et c'est très fluide avec lynx . J'en profite donc car je ne l'ai pas encore fait pour vous dire un gros bravo pour la mise a jour.
Avatar de Algo D.DN Algo D.DN - Membre éprouvé https://www.developpez.com
le 07/04/2014 à 16:28
Sur de vieux PC's je constate une différence d'accès assez significative, en souhaitant que dans la continuité (hors bande passante) ces performances restent durables...
Avatar de imikado imikado - Rédacteur https://www.developpez.com
le 08/04/2014 à 9:19
Vos améliorations sont efficace en effet.
Par contre, je me demande si vous n'avez pas également désactiver la possiblité d'insérer une image dans le post: ça affiche un lien vers l'image et non plus l'image comme avant
Cela fait peut être parti des améliorations de performances
Avatar de Darkzinus Darkzinus - Expert éminent https://www.developpez.com
le 08/04/2014 à 11:06
Bonjour, effectivement le gain est notable. Merci pour cette évolution bienvenue !
Avatar de imikado imikado - Rédacteur https://www.developpez.com
le 08/04/2014 à 13:03
ok merci pour l'info, j'ai du ré-éditer un de mes messages 4 ou 5 fois pour comprendre pourquio l'image ne s'affichait pas : je l'ai meme converti de png en jpg au cas où
Avatar de bernard59139 bernard59139 - Membre chevronné https://www.developpez.com
le 11/04/2014 à 6:45
Perso, au boulot, ca devient difficile de consulter les forums, et encore plus dur de répondre aux messages.

ce qui se passe:
  1. la page commence à se charger, quelques images/boutons/liens s'affichent en haut de l'écran
  2. blocage de ie, impossible de faire quoi que ce soit, comme geler, pendant quelques secondes (15-20)
  3. la page finit de se charger


et parfois des "timeout" reseau quand j'envoie une réponse sur un forum.

Nous avons une vieille version de IE (9..) , un antivirus&firewall régler en mode parano sur proxy et pc.
Offres d'emploi IT
Expert décisionnel business intelligence H/F
Safran - Ile de France - Évry (91090)
Responsable protection des données H/F
Safran - Ile de France - Magny-les-Hameaux (78114)
Data scientist senior H/F
Safran - Ile de France - Magny-les-Hameaux (Saclay)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Accueil