Oracle : pas de nouveau report de Java 8
Même avec des bugs, JDK 8 sera publié le 18 mars

Le , par Hinault Romaric, Responsable .NET
« Même avec des bugs, il sera publié. » Oracle souhaite absolument publier le JDK 8 le 18 mars prochain.

Mathias Axelsson, le gestionnaire du calendrier de JDK 8 chez Oracle, dans un message sur la liste de diffusion du projet, a présenté l’état actuel de celui-ci et réaffirmé son engagement à publier une version stable de la prochaine itération de la plateforme de développement dans deux mois

Initialement prévu pour septembre 2013, Oracle a été obligé de revoir le calendrier de développement de JDK 8, afin d’apporter une réponse aux vagues des failles de sécurité dont avait été victime la plateforme l’an dernier. Ce calendrier prévoit la sortie de la Release Candidate (RC) de JDK 8 le 23 janvier.

Toutefois, Mathias Axelsson précise qu’à ce stade, seuls des « bugs bloquants » seront corrigés dans la version initiale. Les autres seront renvoyés dans une prochaine mise à jour, pour respecter la date de sortie prévue.




Pour rappel, Java 7 avait été également publié avec des bugs, notamment des problèmes avec le compilateur. Ce n’est donc pas nouveau qu’Oracle livre un Java bogué.

Java 8 introduira comme nouveautés : les expressions lambda, le moteur JavaScript Nashorn, les annotations, la nouvelle API « date and time », la convergence des JVM et bien plus. Le projet Jigsaw pour la mise en place d'un système de module a été repoussé à Java 9.

Source : Liste de diffusion JDK 8


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Traroth2 Traroth2 - Membre chevronné https://www.developpez.com
le 15/01/2014 à 14:53
Java 7 a conservé une mauvaise réputation qui fait que je ne connais absolument personne qui se sert de ses fonctionnalités, deux ans et demi après sa publication...
Avatar de Matthieu Vergne Matthieu Vergne - Expert éminent https://www.developpez.com
le 15/01/2014 à 15:00
Moi je viens d'y passer pour pouvoir utiliser Files.newDirectoryStream(path).iterator() pour pouvoir itérer sur un dossier énorme sans perdre du temps à tout lister dès le début et remplir la RAM inutilement. Par contre j'avoue qu'Eclipse est plus stupide pour remplir les generics depuis, vu que certains sont devenus optionnels mais que lui les oublies un peu trop.
Avatar de bruneltouopi bruneltouopi - Membre confirmé https://www.developpez.com
le 15/01/2014 à 16:28
Je ne sais pas sir Je vais me mettre sous Java 8 vu qu'oracle certifie l'existance de bugs.j'ai l'impression qu'oracle de consacre pas ses efforts à resoudre déjà tous les bugs de java7.C'est énorme comment de java6 à java7 on y'a tous ces problèmes.
Il faut vraiment qu'on me donne des raisons tellement valable à de voir migrer.On me dira certainement la sécurité.
Avatar de adiGuba adiGuba - Expert éminent sénior https://www.developpez.com
le 15/01/2014 à 17:20
Citation Envoyé par bruneltouopi Voir le message
Je ne sais pas sir Je vais me mettre sous Java 8 vu qu'oracle certifie l'existance de bugs.j'ai l'impression qu'oracle de consacre pas ses efforts à resoudre déjà tous les bugs de java7.C'est énorme comment de java6 à java7 on y'a tous ces problèmes.
Sincèrement : on est passé à Java 7 sans que cela ne pose aucun problème.

Le bug du projet Lucene était vraiment très spécifique et n'a pas dû toucher grand monde mis à part ceux qui utilisait le projet Lucene.
En plus il avait été résolu assez rapidement...

En plus il ne faut pas tout mélangé lorsqu'on parle de "bugs".
Cela peut regrouper vraiment de tout jusqu'à une simple coquille dans la documentation !

Et justement le message annonce bien que tous les bugs bloquant seront traités en priorité, et que les autres seront remis à plus tard... ce qui est généralement le cas lorsqu'on approche de la "dead-line".
Il n'y a rien d'anormal à cela !

Les produits "zéro-bugs" n'existe pas... à moins de se contenter d'un simple "Hello World".

a++
Avatar de _skip _skip - Expert éminent https://www.developpez.com
le 15/01/2014 à 17:39
Je ne vois pas trop ce que change cette annonce...

La prudence est toujours de mise lorsqu'on upgrade vers une nouvelle version majeure d'un produit, ce n'est pas valable uniquement pour java.
Perso je suis resté en 6 d'une part à cause de lucene que j'utilise et aussi parce que quasiment tout ce qui m'intéressait dans la 7 avait été reporté en 8 donc je voyais pas trop la nécessité d'updater 25 serveurs juste pour me dire "youpie je suis en 7 avec peut-être de nouveaux bugs que je connais pas".
Avatar de plawyx plawyx - Membre expérimenté https://www.developpez.com
le 15/01/2014 à 17:43
Citation Envoyé par bruneltouopi Voir le message

Il faut vraiment qu'on me donne des raisons tellement valable à de voir migrer.
stream, collectors, méthode par défaut dans les interfaces, lambdas.

A mon avis, il y a beaucoup plus de raisons pour passer à jdk 8 que d'avantages procurés lors d'un passage du 6 au 7
Avatar de espresso espresso - Futur Membre du Club https://www.developpez.com
le 15/01/2014 à 20:24
Bonjour. depuis la mise à jour du java aujourd'hui, impossible de jouer sur yahoo billard, ni à d'autres jeux d'ailleurs, et je ne suis pas le seul, beaucoup sont bloqués.
Une fenêtre s'ouvre et précise que application bloquée par les paramètres de sécurité.
Nom ygames_applet
Emplacement http://yog3.games.sp2.yahoo.com
Vos paramètres de sécurité ont bloqué une application non sécurisée.
Connaissez vous une solution ?
cordialement.
Avatar de Traroth2 Traroth2 - Membre chevronné https://www.developpez.com
le 15/01/2014 à 21:11
@espresso : j'ai saisi une conversation au vol aujourd'hui qui parlait d'un truc du genre. Sans garantie donc... Tu as essayé de baisser le niveau de sécurité dans le panneau de configuration Java ?

voir sur http://www.java.com/fr/download/help...p_security.xml en bas de la page.

(C'est sans garantie non plus sur la sécurité de ton système, hein...)
Avatar de Gugelhupf Gugelhupf - Modérateur https://www.developpez.com
le 15/01/2014 à 21:59
C'est un jeu sous forme d'Applet ? C'est peut-être le navigateur qui bloque.
Avatar de espresso espresso - Futur Membre du Club https://www.developpez.com
le 15/01/2014 à 22:00
IE GG Chrome et MF étaient tout les trois bloqués.
Mais j'ai baissé d'un niveau comme tu le dis. effectivement, ça fonctionne en attendant une nouvelle mise à jour.

Merci
Contacter le responsable de la rubrique Accueil