Windows 8.1 : IE11 et Google ne s'accordent pas
Plusieurs utilisateurs notent des soucis avec l'affichage des résultats Google dans IE11

Le , par Stéphane le calme, Chroniqueur Actualités
Peu après une mise à jour vers Windows 8.1, plusieurs utilisateurs ont déjà constaté des soucis avec l’affichage des résultats de recherche Google dans Internet Explorer 11. La page devient difficilement déchiffrable et l'affichage des résultats se fait sur une colonne. Cela affecte aussi bien une navigation avec IE11 sur le Bureau qu'en environnement Modern UI. Certains utilisateurs signalent que d'autres produits Google comme Play App BazaaR, Google Music ou encore Google+ n’interagissent pas normalement.


Microsoft a fait porter à Google le chapeau expliquant que « il semblerait que Google a apporté quelques modifications à son moteur de recherche qui ont influé temporairement le rendu des résultats de recherche pour certains navigateurs. Nous avons déjà fait les ajustements nécessaires pour nous assurer que les clients utilisant Internet Explorer n'en soient pas victimes »

Depuis IE8, Microsoft propose le mode Compatibily View afin d'aider les nouvelles versions de son navigateur à charger les sites âgés conçus pour des versions antérieures d'Explorer. Une liste de sites qui ne s'affichent pas correctement avec les nouvelles versions de navigateur est établie afin que IE puisse passer par ce mode et les charger correctement.

Il semblerait que le moteur de recherche de Google ait été ajouté à cette liste et que, bien que les anciennes versions du navigateur chargent actuellement Google correctement, sur IE11 ce n'est manifestement pas le cas. Conséquence ? La désactivation de cette fonctionnalité résout de facto le problème.

C'est en tout cas ce que suggère une solution apportée sur le forum de Google au problème d'affichage des résultats par un utilisateur. Une fois sur IE11, rendez vous sur Outils, puis sélectionnez paramètres d'affichage et de compatibilité. Décochez simplement la case « utiliser les listes de compatibilité Microsoft » et le rendu des résultats reviendra à la normale.

Source : Page de Support Microsoft , Page de Support Google

Et vous ?

Qu'en pensez-vous ?


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Traroth2 Traroth2 - Expert éminent sénior https://www.developpez.com
le 22/10/2013 à 13:37
J'aimerais comprendre. C'est le code de Google qui ne respecte pas les normes du W3C ou c'est Microsoft qui n'est (toujours) pas capable d'afficher du code aux normes ? Ou les deux ?

Et IE 11 sur le premier Windows 8, ça donne quoi ?
Avatar de ouvreboite ouvreboite - Membre habitué https://www.developpez.com
le 22/10/2013 à 13:59
Citation Envoyé par Traroth2  Voir le message
J'aimerais comprendre. C'est le code de Google qui ne respecte pas les normes du W3C ou c'est Microsoft qui n'est (toujours) pas capable d'afficher du code aux normes ? Ou les deux ?

Et IE 11 sur le premier Windows 8, ça donne quoi ?

- en changeant le user agent d'ie en "chrome", ca s'affiche bien
- en modifiant la liste des sites qui s'affichent en "mode de compatibilité", ca s'affiche bien
- apparemment ca viendrait d'un changement côté Google, d'après MS (http://thenextweb.com/microsoft/2013...ine-correctly/)

Quand on se rappelle comment Google avait "désactivé" le site de Google Maps pour les utilisateurs de Windows Phone (IE10 Mobile) pour raison de "IE10 mobile n'est pas assez bon", alors qu'en changeant l'user agent le site fonctionnait sans problème, ca donne un indice.
Avatar de kaismat kaismat - Membre à l'essai https://www.developpez.com
le 22/10/2013 à 14:00
Voila le résultat du validator W3C :
http://validator.w3.org/check?uri=ht...Inline&group=0
Il n'y a que 30 erreurs et 4 alertes pour une simple page avec un champ et 2 boutons...

Je trouve quand même assez étrange que des sites comme celui de google ne soient pas valides...
Avatar de Squisqui Squisqui - Membre expérimenté https://www.developpez.com
le 22/10/2013 à 14:06
Citation Envoyé par ouvreboite  Voir le message
- en changeant le user agent d'ie en "chrome", ca s'affiche bien
- en modifiant la liste des sites qui s'affichent en "mode de compatibilité", ca s'affiche bien
- apparemment ca viendrait d'un changement côté Google, d'après MS (http://thenextweb.com/microsoft/2013...ine-correctly/)

Quand on se rappelle comment Google avait "désactivé" le site de Google Maps pour les utilisateurs de Windows Phone (IE10 Mobile) pour raison de "IE10 mobile n'est pas assez bon", alors qu'en changeant l'user agent le site fonctionnait sans problème, ca donne un indice.

J'ai remarqué ceci également avec l'user agent. Mais je regrette amèrement de ne pas avoir eu l'idée de tester avec Chrome et l'user agent d'IE11 pour Windows 8.1 =/
Pour moi, ça s'appelle une crasse de la part de Google. Depuis IE9, ce n'est plus autant la galère de développer un site web.
Avatar de fredinkan fredinkan - Membre éclairé https://www.developpez.com
le 22/10/2013 à 14:39
Franchement ça devient un peu n'importe quoi ces actions de google...

Je suis le seul à trouver que ça tient vraiment de batailles de garderie ?
Avatar de loufab loufab - Rédacteur/Modérateur https://www.developpez.com
le 22/10/2013 à 14:42
En 8.0 aucun problème, avec le passage en 8.1 le problème s'est produit. Il me semble pourtant que le navigateur IE a toujours la même version.

En tout cas dans quelques jours fini igoogle et son widget News. Et cela n'a rien à voir avec Microsoft.
Avatar de DotNET74 DotNET74 - Membre expérimenté https://www.developpez.com
le 22/10/2013 à 14:44
ça s'appelle la Google touch !!!!

Ils aiment bien jouer sur la pelouse des autres mais ne tolèrent pas qu'on viennent jouer sur leur pelouse ...
Avatar de RhoManu RhoManu - Membre du Club https://www.developpez.com
le 22/10/2013 à 14:47
@loufab: Non, passé de V10 à V11.

@kaismat: Cette page fait des millions de vue chaque minute, le moindre octet leur est crucial, alors ils font passer le fonctionnel avant le valide.

Du coup, le champ que tu vois n'en est pas un, ou du moins il est à l'intérieur de l'élément que tu crois être un champ... 'Fin c'est compliqué leur mise en page.
Avatar de Arkal Arkal - Membre régulier https://www.developpez.com
le 22/10/2013 à 14:54
@fredinkan non tu n'es pas le seul...

c'est du anti-microsoft bashing... c'est trop facile à faire...
on critique on rit de microsoft et non a l'esprit fermé aux nouveautés et à l'amélioration de microsoft!
Avatar de loufab loufab - Rédacteur/Modérateur https://www.developpez.com
le 22/10/2013 à 16:21
@RhoManu : Je me suis mal exprimé : Avant la mise à jour 8.1 faite le 18, aucun problème, je n'ai constaté le problème que hier soir, donc 3 jours sans rien constaté et avec la même version de IE (v11).
Offres d'emploi IT
Ingénieur analyste programmeur (H/F)
Safran - Auvergne - Montluçon (03100)
Ingénieur développement fpga (traitement vidéo) H/F
Safran - Ile de France - 100 rue de Paris 91300 MASSY
Consultant sap finance/controlling H/F
Safran - Ile de France - Vélizy-Villacoublay (78140)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Accueil