jQuery 2.0.0 est disponible
Plus rapide et 12 % plus légère que la version 1.9.1

Le , par danielhagnoul, Rédacteur
jQuery 2.0.0 est disponible
Plus rapide et 12 % moins "lourde" que la version 1.9.1

Cette version abandonne les versions obsolètes d'Internet Explorer (IE 6, 7 et 8), elle est plus rapide et moins lourde.

L'équipe de développement travaille déjà sur le futur de la branche compatible IE : la branche 1.10 sortira rapidement.

Dans le futur les deux branches évolueront en parallèle :

  • 1.10.0 et 2.0.0
  • 1.11.0 et 2.1.0
  • etc.


Rappelez-vous que les sites web de production doivent toujours demander une version précise de jQuery, utiliser une version indéterminée d'une branche ou jquery-latest.js est fortement déconseillé pour la performance et la maintenance de votre site web.

La version 2.0.0 sera disponible sur tous les serveurs de code dans quelques jours, elle est déjà disponible sur le serveur de code de jQuery : <script src="http://code.jquery.com/jquery-2.0.0.min.js"></script>.

Si vous mettez à jour depuis une version antérieure à la 1.9, nous vous recommandons d'utiliser le plugin jQuery Migrate et de lire le Guide de mise à niveau jQuery 1.9, car il ya eu beaucoup de changements. Il est facile d'utiliser le plugin Migrate, il suffit de l'inclure après jQuery et d'ouvrir votre console navigateur pour voir les messages qu'il génère:

Code : Sélectionner tout
1
2
<script src="http://code.jquery.com/jquery-2.0.0.min.js"></script> 
<script src="http://code.jquery.com/jquery-migrate-1.1.1.min.js"></script>
Seul l'usage de la branche 2.0 de jQuery est recommandé pour les utilisations "modernes", par exemple :

  • Google Chrome add-ons
  • Mozilla XUL apps and Firefox extensions
  • Firefox OS apps
  • Chrome OS apps
  • Windows 8 Store (“Modern/Metro UI”) apps
  • BlackBerry 10 WebWorks apps
  • PhoneGap/Cordova apps
  • Apple UIWebView class
  • Microsoft WebBrowser control
  • node.js (combined with jsdom or similar)


Liste complète des modifications et source


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Wily le Programmeur Wily le Programmeur - Futur Membre du Club https://www.developpez.com
le 20/06/2013 à 18:02
La version 2 est elle compatible avec les anciennes versions des UI?
Avatar de danielhagnoul danielhagnoul - Rédacteur https://www.developpez.com
le 20/06/2013 à 19:52
Il y a eu plusieurs ruptures de rétro compatibilité lors de l'évolution du code de jQuery (1.8 vers 1.9) et de jQuery UI (1.9 vers 1.10).

En conséquence, je ne pense pas que la branche 2 de jQuery soit totalement compatible avec jQuery UI en dessous de la version 1.10.0.
Offres d'emploi IT
RESPONSABLE WEB ANALYTICS F/H
VACALIANS GROUP - Languedoc Roussillon - SETE (34)
Développeur Web FULL-STACK
VACALIANS GROUP - Languedoc Roussillon - SETE (34)
Développeur WEB PHP F/H
VACALIANS GROUP - Languedoc Roussillon - SETE (34)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Accueil