Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

RIA : Java FX 1.2 est déjà disponible en téléchargement avant l'ouverture de JavaOne
Une version plus mature ?

Le , par galien

1KPARTAGES

0  0 
Après un petit jeu de piste j'ai réussi à télécharger la 1.2 (Windows, Mac, Solaris x86, Linux)

Les nouveautés

Citation Envoyé par kajava Voir le message
JavaFX dans sa version 1.2 arrive enfin sur Linux

Plateforme de test (Fedora 10)

http://java-javafx-iipt.blogspot.com...-linux-12.html
Citation Envoyé par galien Voir le message
Pour ceux que cela intéresse la première journée de javaone avec par le menu:

JavaFX sur une télé LG.
L'outil de création style flexbuilder.
L'app store en javaFX.
Les déclarations plus que rassurante du pdg d'Oracle sur le futur de javaFX (il voit bien OpenOffice version javaFX).
La vidéo:
http://java.sun.com/javaone/2009/general_sessions.jsp
Ce sont finalement plutôt des bonnes nouvelles pour tout ceux qui appartiennent à l'encore trop petite communauté javaFX.
Mise à jour du Plugin Eclipse

Comme d'habitude le blog de james weaver vous donnera quelques infos dessus.

http://learnjavafx.typepad.com/weblog/

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de Ricky81
Expert éminent sénior https://www.developpez.com
Le 01/06/2009 à 18:50
Est ce qu'on peut s'attendre à une version plus mature qui va pouvoir faire face à la concurrence, ou faudra-t-il attendre une 2.0 ?
0  0 
Avatar de vbrabant
Expert éminent sénior https://www.developpez.com
Le 01/06/2009 à 19:18
au fait, les nouveautés JavaFX 1.2 sont décrites là http://javafx.com/do...ticles/javafx1-2.jsp
Mais le plus important à savoir est que JavaFX 1.2 n'est pas compatible JavaFX 1.1 (qui n'était pas compatible JavaFX 1.0)

Et toujours pas de version annoncée pour Linux
0  0 
Avatar de *alexandre*
Inactif https://www.developpez.com
Le 01/06/2009 à 21:32
quel est l intérêt de java fx franchement ? les développeurs java ne sont pas censée faire du flash ...
0  0 
Avatar de galien
Membre averti https://www.developpez.com
Le 01/06/2009 à 22:16
Y'a la version Linux et Solaris x86
Il semble de plus que le jdk update 14
0  0 
Avatar de entreprise38
Inactif https://www.developpez.com
Le 01/06/2009 à 23:15
Une chose me rébute énormément chez JavaFX : l'incompatiblité entre les versions (comme dit plus haut).
Etant dans un univers imprégné de Java, la moindre des choses aurait été de préserver cette compatiblité, non ? Ou celle-ci est-elle facilement franchissable ? Suffit-il seulement de recompiler avec le SDK visé ? (si ce n'est que ça... ça va, sinon je pleure)

Merci
0  0 
Avatar de galien
Membre averti https://www.developpez.com
Le 02/06/2009 à 0:21
Pour les changement et les incompatibilités:
http://www.javafx.com/docs/articles/javafx1-2.jsp
Sinon entreprise38 c'est en effet un peu embêtant mais étant donné la maturité de javaFX ce n'est pas si surprenant. Enfin l'API de composants graphique est définie, les problèmes viendront d'ailleurs principalement de ce coté. Sun l'avait cependant annoncé, ce n'est donc pas une surprise. Rassurons nous, les prochaines versions seront certainement rétro compatibles, comme java l'est aujourd'hui.
0  0 
Avatar de bouye
Rédacteur/Modérateur https://www.developpez.com
Le 02/06/2009 à 1:00
Bah mieux vaut qu'ils modifient puis finalisent ENFIN l'API plutot que de garder des trucs deprecated pendant des annees. Apres... apres la pilule serait probablement mieux passee si la version 1.0 et 1.1/1.1.1 avaient ete respectivement appellees beta 98 et beta 99. Reste plus qu'a esperer que la version 1.2 soit la VRAIE version finale et non-pas une etape intermediaire de plus. Pis pour le futur, faudra aussi voir ce qu'Oracle en fait et des infos qu'on pourrait glaner a la JavaOne.

Citation Envoyé par *alexandre*

les développeurs java ne sont pas censée faire du flash ...
Ahhh pourtant si mes souvenirs sont bons Java a commence en rajoutant des animations dans des pages web... Y a des trucs qui sont IMMENSEMENT plus compliques a faire en Java2D + JMF + JAI alors que c'est les doigts dans le nez en JavaFX.

Mais bon... *gosh* va me falloir repasser sur tous mes exemples de test... enfin une fois les telechargements effectues.
0  0 
Avatar de bouye
Rédacteur/Modérateur https://www.developpez.com
Le 02/06/2009 à 1:22
Ben a la vue des changements c'est pas encore ca...

Mais ou est passe le language oriente pour les designers... ?

Mixins ?
0  0 
Avatar de Fr3nchK1ss
Nouveau membre du Club https://www.developpez.com
Le 02/06/2009 à 9:54
Un langage pour les designers? Hey ils vont pas quand même venir nous voler notre travail
Bon, comme prévu on va souffrir, c'est pas rétro compatible et ça bouge pas mal. Mais je suis quand même content qu'ils aient amélioré la gestion des layouts et les perfs globales. Et puis une 1ère compatibilité linux officielle ça se fête non?
Ce début de semaine va être rude...
0  0 
Avatar de galien
Membre averti https://www.developpez.com
Le 02/06/2009 à 10:52
Je vois pas vraiment pourquoi cette étiquette de langage pour les designers.
C'est plutôt un langage moderne avec une grosse api graphique, des fonctionnalité bien pratiques mais pas forcément réservé au designers.
L'outil du graphiste est la souris pas le clavier!
Pour rester sur le design il semble que pour le prochain plugin netbeans on aura le support natif du svg actuellement juste implémenté pour le plugin ME
http://wiki.netbeans.org/NewAndNoteWorthyNB67#section-NewAndNoteWorthyNB67-FullSupportForSVGRichComponentsInTheVisualMobileDesigner
Quand netbeans rencontre photoshop...
0  0