Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

L'interpréteur alternatif PyPy 1.4 est disponible
Ainsi que deux nouvelles versions du langage : Python 2.7.1 et Python 3.1.3

Le , par Katleen Erna

62PARTAGES

0  0 
L'interpréteur alternatif PyPy 1.4 est disponible, de même que deux nouvelles moutures du langage qu'il concerne : Python 2.7.1 et Python 3.1.3

Voici une information qui intéressera sûrement les développeurs Web. PyPy, un projet qui était jusqu'à présent considéré comme non stable, vient d'être mis à jour. Et il y a gagné en performances : il est désormais, selon ses concepteurs, assez fiable pour être utilisé en production (sous Linux x86, 32 ou 64 bits).

Pour ceux qui ne connaissent pas encore cet outil, il s'agit d'une alternative à l'interpréteur officiel du langage Python (CPython). Son secret ? Disposer d'un compilateur just-in-time, qui lui permet d'être deux fois plus rapide que la solution officielle. Ce dernier est d'ailleurs tout nouvellement compatible avec le x86 64 bits.

PyPy 1.4, qui vient de sortir, permet donc d'exécuter du code Python (RPython), sans négliger la sécurité des serveurs puisqu'un bac à sable lui a été ajouté.

De quoi offrir de nouvelles perspectives de programmation web dans les environnements open-source.

Petit bonus, le langage de programmation lui-même s'est offert un lifting ce week-end, avec l'arrivée de deux nouvelles versions.

Liens de téléchargement de :

PyPy 1.4

Python 2.7.1

Python 3.1.3

Et vous ?

Etes-vous content de l'arrivée de ces nouvelles versions ? Allez-vous les utiliser ? Pourquoi ?

Une erreur dans cette actualité ? Signalez-le nous !