Developpez.com

Une très vaste base de connaissances en informatique avec
plus de 100 FAQ et 10 000 réponses à vos questions

Un plug-in permet d'exécuter Internet Explorer 6 dans Internet Explorer 8
Unibrows a été développé par des anciens de Microsoft

Le , par Hinault Romaric, Responsable .NET
La start-up Browsium a dévoilé un nouveau plug-in pour Internet Explorer 8 qui devrait permettre d’exécuter IE6 dans un onglet du navigateur.

Le produit, baptisé « Unibrows », a été mis au point par des anciens de Microsoft.

Unibrows a pour but de permettre aux entreprises de passer à des technologies modernes comme Windows 7 et IE8 tout en maintenant la compatibilité avec les applications Web ou métiers qui s'appuient sur IE6. Le tout, bien sûr, sans changer une seule ligne de code.

« Les entreprises ont besoin de quelque chose de simple qui n’est pas fondée sur la virtualisation » croit savoir Matthew Heller, le PDG fondateur de Browsium.

Selon Gartner Research, les problèmes de rétro-compatibilité avec IE6 devraient retarder la migration des projets sur Windows 7 de 20 % des entreprises. Ils devraient également engendrer des frais plus élevés que le budget prévu. Environ 40% des applications Web utilisées par les entreprises encore en cours sur IE6 ne fonctionneront pas sur IE8, navigateur livré par défaut avec Windows 7.

Pour résoudre ces problèmes, « Unibrows s’exécute comme un processus local sur la machine », explique Matt Crowley. « Unibrows est un processus lié à IE8 qui est déclenché sur la machine suivant des règles définies par les administrateurs, à ce moment-là Unibrows swaps dans les DLL IE6 pour afficher la page ou l’application dans l’onglet IE8 ».

Unibrows peut fonctionner sur n’importe quelle version de Windows qui supporte IE8 et prend en charge toutes les fonctionnalités d'IE6 y compris les contrôles ActiveX.

Le beta du plug-in est disponible après inscription sur cette page


Source : Browsium

Et vous ?

Ce plug-in va-t-il encourager la migration sur Windows 7 ?
Allez-vous l'essayer (ou tenter de le faire essayer) dans votre entreprise ?

En collaboration avec Gordon Fowler


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de kapok kapok - Nouveau membre du Club https://www.developpez.com
le 04/11/2010 à 15:47
très très très bonne chose

ça pourrait permettre aux entreprises d'enfin migrer leur parc informatique sans devoir débourser des millions pour refondre leurs applications ne tournant que sur ie6

j'adore les anciens de microsoft qui vont se faire des thunes sur le dos de leur ancien employeur
Avatar de rebolon rebolon - Membre habitué https://www.developpez.com
le 04/11/2010 à 16:03
Excellente îdée, comme ça on gardera les super backdoors d'IE6 sur windows 7.
Et en plus, rien ne garantie la sécurité d'unibrows...
Avatar de barmic barmic - Membre habitué https://www.developpez.com
le 04/11/2010 à 16:07
"des technologies modernes comme Windows 7 et IE8"

Ha! Ha !....

--------> []
Avatar de Hellwing Hellwing - Membre chevronné https://www.developpez.com
le 04/11/2010 à 16:19
Citation Envoyé par rebolon  Voir le message
Excellente îdée, comme ça on gardera les super backdoors d'IE6 sur windows 7.
Et en plus, rien ne garantie la sécurité d'unibrows...

J'ose espérer que justement les contrôles d'IE8 serviront de filet de sécurité à ce plugin pour empêcher les failles d'IE6 d'être exploitées.

M'enfin je me doute bien que c'est bien plus facile à dire qu'à faire.
Avatar de Jonathan38 Jonathan38 - Nouveau membre du Club https://www.developpez.com
le 04/11/2010 à 16:28
Je vois pas ou est le problème du cout, rien n'empêche quelqu'un de charger une nouvelle version d'IE sans changer de machine...

Mais c'est vrai que mise à part ça, je pense que ce n'est pas une bonne idée... les gens vont trainer des brouettes et se plaindre en disant, "Tiens, je comprend pas, ça fonctionne pas !!"
Avatar de palnap palnap - Membre habitué https://www.developpez.com
le 04/11/2010 à 16:48
« Les entreprises ont besoin de quelque chose de simple qui n’est pas fondée sur la virtualisation » croit savoir Matthew Heller, le PDG fondateur de Browsium.

lol, il a pas tort pourtant
Avatar de Hellwing Hellwing - Membre chevronné https://www.developpez.com
le 04/11/2010 à 17:25
Citation Envoyé par Jonathan38  Voir le message
Je vois pas ou est le problème du cout, rien n'empêche quelqu'un de charger une nouvelle version d'IE sans changer de machine..."

Non, le coût vient de l'adaptation des applications IE6 existantes aux normes et exigences d'IE8, pas au changement des postes de travail.

Mon client effectue actuellement une étude sur le passage d'IE6 vers IE8. Nous en tant que développeurs on doit s'assurer que les applications tourneront toujours aussi bien... Et évidemment on va devoir les remettre à niveau, tout retester, repasser sur tous les écrans etc., ce qui risque de prendre du temps et de coûter cher.
Ce plugin permettrait dans ce cas-là de garder les applications existantes sous IE6, MAIS de développer les futures applications sous IE8.

Comme ça on ne s'embête pas avec a compatibilité de l'existant et on a accès aux technologies plus récentes pour les applications à venir (au lieu de les créer sciemment pour un navigateur obsolète)
Avatar de ILP ILP - Membre averti https://www.developpez.com
le 04/11/2010 à 18:06
Euh, pourquoi réinventer la roue ? Cette fonction existe déjà dans Internet Explorer. Il suffit de mettre la balise :
Code HTML : Sélectionner tout
1
2
3
4
5
6
7
<!-- Mimic Internet Explorer 7 --> 
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" > 
  
<meta http-equiv="X-UA-Compatible" content="IE=4">   <!-- IE5 mode --> 
<meta http-equiv="X-UA-Compatible" content="IE=7.5"> <!-- IE7 mode --> 
<meta http-equiv="X-UA-Compatible" content="IE=100"> <!-- IE8 mode --> 
<meta http-equiv="X-UA-Compatible" content="IE=a">   <!-- IE5 mode -->
dans l'en-tête HTML.
Avatar de dodelria dodelria - Nouveau Candidat au Club https://www.developpez.com
le 04/11/2010 à 18:15
Très mauvaise idée, IE6 est obsolète et ne devrait donc plus etre suporté. Ce genre d'initiative ne fera que retarder la migration.

Ce plugin rencontrera surement un peu de succès, pour les devs voulant une "parfaite" compatibilité, et si ce plugin n'est pas compatible IE9, alors se sera encore plus difficile de faire migrer les personnes utilisant IE8, qui est déjà légèrement obsolète ...
Avatar de camus3 camus3 - Membre éprouvé https://www.developpez.com
le 04/11/2010 à 19:46
intéressant , merci !
Très mauvaise idée, IE6 est obsolète et ne devrait donc plus etre suporté. Ce genre d'initiative ne fera que retarder la migration.

je pense que le métier de dev n'est pas de choisir sur quel navigateur le client doit regarder son app , mais plus d'être compatible avec le plus grand nombre de nav pour toucher le plus de monde, si ta cible tourne sous ie6 , il faut faire en sorte que ... maintenant si tu cibles du geek sur ipad, tu t'en fous bien évidement. Je me souviens d'un projet de refonte ou 20% des 10 000 visiteurs quotidiens utilisaient ie6 voir 5.5 ... on fait faire perdre 20% de chiffre à la boite qui paie le projet parce qu'on est IN et qu'on fait que du nec plus ultra HTML5 ? non bien sur.
Avatar de Flaburgan Flaburgan - Modérateur https://www.developpez.com
le 04/11/2010 à 21:52
Je pense que ce n'est pas une si mauvaise chose. J'ai eu la surprise de recevoir dernièrement un pc neuf de mon entreprise (STMicroelectronics), qui a été reformaté de windows 7 a Xp avec ie6. Quand j'ai posé la question, on m'a répondu que certaines appli de développé à la boite nécessitait IE6 pour fonctionner. Comme on a pas le temps et le budget pour redev ces applis, on garde IE6, et donc on garde Xp. Conclusion, tout est retardé pour une histoire de compatibilité, qui pourrait être résolu par ce plugin.

Après effectivement si c'est pour garder les failles de sécurité d'IE6...
Offres d'emploi IT
Architecte sécurité des systèmes d'information embarqués H/F
Safran - Ile de France - 100 rue de Paris 91300 MASSY
Ingénieur H/F
Safran - Ile de France - Moissy-Cramayel (77550)
Architecte et intégrateur scade/simulink H/F
Safran - Ile de France - Vélizy-Villacoublay (78140)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Accueil