Firefox s'acharne contre les plug-ins périmés
Et avertit plus sérieusement ses utilisateurs pour les mettre à jour

Le , par Nissa Comet, Expert Confirmé Sénior
Les utilisateurs de Firefox risquent à l’avenir d’être harcelés par les notifications de mises à jour fréquentes des plug-ins périmés, ces sources inépuisables de problèmes de sécurité.

En effet, Firefox compte appeler plus fermement à l’installation de ces mises à jour, et ce à partir de chaque page qui y fait appel, alors qu’il faut actuellement aller expressément sur le gestionnaire des extensions. Selon les développeurs de Firefox, cela concerne les versions obsolètes de Silverlight, Adobe Reader, Adobe Flash et autres, mais cette vérification n’est disponible pour le moment que sur le système d’exploitation Windows.

Mozilla a aussi prévu un site Web de vérification de plug-ins où les utilisateurs peuvent se rendre pour effectuer une révision de leur navigateur. Sur cette adresse, il est possible de vérifier ses composants et de voir quelles sont les mises à jour à installer.


Selon le blog officiel de Mozilla, ces mises à jour sont vraiment importantes et les négliger pourrait causer beaucoup de dégâts. En effet elles permettent de profiter des meilleures fonctionnalités, d’échapper aux failles de sécurité et de bénéficier d’une meilleure expérience utilisateur, stable et sûre.

Plug-in Check : vérifiez si votre navigateur est à jour

Source : Blog de Mozilla

Et vous ?
Pensez-vous que ce soit le meilleur moyen ou la seule solution que puisse utiliser Firefox pour que ses utilisateurs bénéficient d’une meilleure expérience Web ?


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Barsy Barsy
http://www.developpez.com
Expert Confirmé
le 09/10/2012 11:47
Citation Envoyé par Jon Shannow  Voir le message
C'est ce qui m'a fait abandonner Firefox au profit de Google Chrome !

Enfin, ce reproche vaut aussi pour Google Chrome qui a été le premier à pratiquer le fait de sortir une nouvelle version majeure chaque mois.
Avatar de Jon Shannow Jon Shannow
http://www.developpez.com
Expert Confirmé
le 09/10/2012 13:36
Citation Envoyé par Barsy  Voir le message
Enfin, ce reproche vaut aussi pour Google Chrome qui a été le premier à pratiquer le fait de sortir une nouvelle version majeure chaque mois.

Sauf que Chrome le fait de manière transparente. Je suis à jour avec Chrome sans avoir vu un seul écran : vous devez mettre à jour blabla. Faut redémarrer FF, puis là, une page avec la liste des plugins/extensions qui ne sont plus valables pour cette version. A peine, la version du plugin/extension mise à jour, que FF sortait à nouveau un version et on c'était reparti !
Avatar de Uther Uther
http://www.developpez.com
Expert Confirmé Sénior
le 09/10/2012 14:19
Citation Envoyé par Barsy  Voir le message
En même temps, si Firefox n'avait pas sorti une version majeure tous les mois, il est probable que les plug-ins périmeraient moins vite.

C'est tout le contraire : ici il ne s'agit pas d'extension périmées à cause des montées de version mais de plugins qui contiennent des failles de sécurités.
Les plugins(flash, silverlight, java,...) utilisent la NPAPI qui est stable. Ils continuent donc de fonctionner quelque que soit la version de Firefox.

Citation Envoyé par Barsy  Voir le message
A force, j'ai fini par définir dans la config de l'extension qu'elle est compatible jusqu'à la version 50 de FF pour être tranquille...

Maintenant ce problème est en grande partie résolu, l’incrémentation du numéro se fait automatiquement, si aucune fonctionnalité du plugin n'a été modifiée.

Citation Envoyé par Barsy  Voir le message
Je ne sais pas quelle mouche a piqué Mozilla pour que soudain, ils se mettent à ne faire que des versions majeures alors que les évolutions sont mineures. Il était inutile de copier le fonctionnement de Chrome là dessus que je trouvais déjà ridicule.

Je t'invites à lire ces auncien sujets ou j'explique pourquoi, ce n'est pas une lubie mais que ca répond a un vrai besoin:
http://www.developpez.net/forums/d11...a/#post6416715
http://www.developpez.net/forums/d11...a/#post6416963
http://www.developpez.net/forums/d11...a/#post6419385

Citation Envoyé par Jon Shannow  Voir le message
Sauf que Chrome le fait de manière transparente. Je suis à jour avec Chrome sans avoir vu un seul écran : vous devez mettre à jour blabla. Faut redémarrer FF, puis là, une page avec la liste des plugins/extensions qui ne sont plus valables pour cette version. A peine, la version du plugin/extension mise à jour, que FF sortait à nouveau un version et on c'était reparti !

Depuis Firefox 15, les mises à jour sont aussi silencieuses par défaut et contrairement a Chrome, Il est possible de changer ce fonctionnement si on le souhaite.
Les plugins restent compatible et les extensions ne sont plus désactivées(sauf en cas de problème connu) depuis le version 10.
Avatar de Jon Shannow Jon Shannow
http://www.developpez.com
Expert Confirmé
le 09/10/2012 14:40
Citation Envoyé par Uther  Voir le message
Depuis Firefox 15, les mises à jour sont aussi silencieuses par défaut et contrairement a Chrome, Il est possible de changer ce fonctionnement si on le souhaite.
Les plugins restent compatible et les extensions ne sont plus désactivées(sauf en cas de problème connu) depuis le version 10.

Oui, je sais, mais voilà, j'ai pris mes habitudes sous Chrome et tant qu'il ne me décevra pas, je ne vois aucune raison d'en changer. Pour l'instant, je n'ai rien à reprocher à Chrome.
J'ai utilisé la suite Mozilla, puis le couple Firefox/Thunderbird et aujourd'hui Chrome/Thunderbird (c'est pas que je trouve Thunderbird exceptionnel, mais je n'en ai pas trouvé qui me satisfasse d'avantage, ce qui ne fut pas le cas avec FF). Quand Chrome est sorti, je n'ai rien trouvé qui m'encourage à quitter FF. Et je serais certainement resté avec FF si ce dernier n'avait pas eu ce comportement très agaçant, à l'époque.
Avatar de tabouet tabouet
http://www.developpez.com
Membre éclairé
le 09/10/2012 14:41
Franchement, les mises à jours pour la sécurité ou pour apporter des nouvelles fonctions, c'est bien mais faudrait voir à ne pas abuser...
Quand mon PC s'allume, je passe plus de temps à faire les mises à jours qu'à bosser.
Avatar de sevyc64 sevyc64
http://www.developpez.com
Modérateur
le 09/10/2012 17:16
Citation Envoyé par tabouet  Voir le message
Franchement, les mises à jours pour la sécurité ou pour apporter des nouvelles fonctions, c'est bien mais faudrait voir à ne pas abuser...
Quand mon PC s'allume, je passe plus de temps à faire les mises à jours qu'à bosser.

Allume le plus souvent !!

Le miens tourne tous les jours, et les mises à jour (toutes en automatiques quand c'est possible) je n'y fait même plus attention.

Au point que je ne sais même pas en quelle version je suis de FF ou de Chrome
Avatar de alex_vino alex_vino
http://www.developpez.com
Membre Expert
le 09/10/2012 18:46
Citation Envoyé par sevyc64  Voir le message
Allume le plus souvent !!

Le miens tourne tous les jours, et les mises à jour (toutes en automatiques quand c'est possible) je n'y fait même plus attention.

Au point que je ne sais même pas en quelle version je suis de FF ou de Chrome

Les mises a jour silencieuses de Firefox sont récentes.
Mais c'est vrai que depuis je n'ai aucun probleme avec les notifications.
Avatar de Kiiwi Kiiwi
http://www.developpez.com
Membre Expert
le 09/10/2012 19:00
Citation Envoyé par hotcryx  Voir le message
Lol, tu ferais bien d'ajouter Ghostery (un block trackers)

Personnellement, j'ai eu un sentiment d'extrême lourdeur avec ce module.

Quoi qu'il en soit, j'ai quasiment tout viré comme modules, et j'en ai plus que 3. 2 que je considères indispensables quotidiennement, quant aux 3èmes, je l'utilise qu'occasionnellement, mais c'est un module qui exige un redémarrage de firefox à chaque activation/désactivation... donc question pratique, il reste activé. Et je peux te dire que actuellement, firefox il tourne très bien.
Il reste un peu moins fluide qu'Opera, mais y a pas à s'en plaindre.

Je ne connais pas le "firefox usine à gaz" dont parlent tous ses détracteurs.

Citation Envoyé par Uther  Voir le message
Je t'invites à lire ces auncien sujets ou j'explique pourquoi, ce n'est pas une lubie mais que ca répond a un vrai besoin:
http://www.developpez.net/forums/d11...a/#post6416715
http://www.developpez.net/forums/d11...a/#post6416963
http://www.developpez.net/forums/d11...a/#post6419385

Certes, mais ce que je reproche à Mozilla c'est d'avoir instauré ce cycle de développement rapide dans la précipitation.
Il aurait fallu au moins attendre les mises à jour silencieuses...
même les habitués de firefox en ont eu marre de ce rythme l'année dernière.
Les modules complémentaires ne suivaient pas, du coup on attendait pour faire la mise à jour, chaque démarrage elle voulait se faire, quand enfin on mettait à jour ff, la semaine d'après y avait une nouvelle version, etc
c'était soulant soulant soulant, à tel point qu'à cette époque je me suis rapproché d'Opera... et même d'IE9.

Et ça a gardé des traces, même maintenant que les mises à jours sont plus discrètes, je n'utilise plus autant firefox qu'avant. ça reste mon navigateur principal, mais souvent j'utilise Opera (pas IE9, il est très bien, mais définitivement pas pour moi).
Avatar de daYop daYop
http://www.developpez.com
Membre à l'essai
le 09/10/2012 22:46
Sérieusement, qui utilise encore quicktime ?
faut s'en débarrasser le système ne s'en portera que mieux !
Avatar de minnesota minnesota
http://www.developpez.com
Membre Expert
le 10/10/2012 21:28
Salut,

Pour ceux qui sont concernés par ce problème vous pouvez aller dans les paramètres de configuration via about:config (à taper dans la barre d'adresse) et mettre une chaine vide pour la valeur "plugins.update.url"... y'a aussi le booléen "plugins.update.notifyUser", mais il semble être sans effet...

ça peut vous être utile car si vous continuez à entretenir une version antérieure de Firefox (3.6 par exemple), certains récents plug-ins ne seront tout simplement pas compatibles avec, mais indépendamment de cela, même pour les dernières versions de Firefox, il y a des composants ou plugins qu'on ne peut pas mettre à jour "sans danger"...

Un problème de taille par exemple, c'est que si vous disposez d'Adobe Acrobat, et que si vous mettez à jour le plugin Adobe reader vers une version majeure, il y a un risque de conflit très important entre les deux, alors que s'il y a une faille, une simple mise à jour mineure du plugin sera suffisante, mais il sera quand même considéré comme obsolète par Mozilla :

Citation Envoyé par Adobe
Note: Adobe Technical Support does not recommend or support having multiple versions of Acrobat or Adobe Reader installed on the same machine. (For example, don't run Acrobat 8 with Adobe Reader 9 or Acrobat 7 with Adobe Reader 8). Acrobat and Adobe Reader have numerous components that have similar functionality and can cause conflicts on a machine. The most prevalent among these conflicts involves the plug-ins for rendering PDF files in the browser, PDFMaker inside Office Applications, and the Adobe PDF printer. Using the Version Interoperability table below, remove all versions of Acrobat and Adobe Reader, and then install the current version.

Avatar de goomazio goomazio
http://www.developpez.com
Membre Expert
le 11/10/2012 19:22
Citation Envoyé par nissacomet  Voir le message
Pensez-vous que ce soit le meilleur moyen ou la seule solution que puisse utiliser Firefox pour que ses utilisateurs bénéficient d’une meilleure expérience Web ?

Je me demande s'ils ne devraient pas rendre uniquement les MAJ de sécurité obligatoires/incontournables, parce que les nouvelles fonctionnalités peuvent apporter de nouvelles failles : toute version périmée a un jour été nouvelle.
Offres d'emploi IT
TRAFFIC MANAGER CHARGÉ (E) SEARCH ENGINE MARKETING (H/F)
CDI
WURTH MODYF FRANCE - France - erstein (67150)
Parue le 04/12/2014
Système d'information pour gestion de configuration véhicule
Stage
Renault - Ile de France - Guyancourt (78280)
Parue le 16/12/2014
Administrateur netbackup h/f
CDD
Kobaltt - Midi Pyrénées - Toulouse (31000)
Parue le 04/12/2014

Voir plus d'offres Voir la carte des offres IT
 
 
 
 
Partenaires

PlanetHoster
Ikoula